Solved (Got another problem) Cheat Engine and base address

Hexui Undetected CSGO Cheats Sinkicheat PUBG Cheat

Kalist

Newbie
Full Member
Jul 5, 2015
24
122
0
So I'm trying to find a base address of ammo value in a 64-bit process. Everything works, I find the dynamic pointer to the base address, but when I try to "find out what accesses this address" / "find out what writes to this address" it gives an invalid pointer to a new address closer to the base address.

When Cheat engine says in the "extra info" tab: "The value of the pointer needed to find this address is probably 5047854C", but when I do a new scan for it in hexadecimal value nothing comes up... You might be thinking that it's not the right address, but it IS, because it is the ONLY one showing...

I thought it might be bugged so I tried to close it down and find a new dynamic address pointing to the same base address and search again, but still the same. Is this because I might be using a 32-bit version of Cheat Engine also? If that is the case, could someone post a link to Cheat Engine 64-bit download? Because I can't find a 64-bit version anywhere...

I am sure it is the ammo address, tested it, and it was. Even NOP'ed it to be sure, but this prevents me from finding the base address which I need to make a consistent hack. Else when I restart the game it'll just NOP an entirely different address.

This is what it looks like:

Unavngivet.jpg

Why does Fleep in this turoial not bother finding the base address? He's gonna need that for when the game restarts, right?

https://www.youtube.com/watch?v=etcLp9MIW1w
 
Last edited:

Rake

Cesspool Admin
Administrator
Jan 21, 2014
12,140
78,998
2,394
Try not to get too far ahead of yourself! If you don't understand pointers yet I wouldn't learn something more advanced, how pointers work are a fundamental concept you need to understand. I definately struggled with this, but one day it just CLICKS with you and then you understand it perfectly :)

Cheat Engine Tut 2

How To Hack Any Game 1 Solaire

How to Hack Any Game pt 2 Rake

Pointer Scanning Like a Boss
 
Last edited:

Kalist

Newbie
Full Member
Jul 5, 2015
24
122
0
Fixed, found the 64Bit Cheat Engine executable and had to run as administrator.

Ah wtf, now when I finally find results none of these pointer are accessed by anything. Screw working with pointers, I'm gonna look into codecaving so I can avoid having to go through this.
 
Last edited:

Obsta

Jr.Hacker
Meme Tier VIP
Jan 27, 2014
394
2,978
17
If you can't work out your issue use the pointer scanner
 
Attention! Before you post:

Read the How to Ask Questions Guide
99% of questions are answered in the Beginner's Guide, do it before asking a question.

No Hack Requests. Post in the correct section.  Search the forum first. Read the rules.

How to make a good post:

  • Fill out the form correctly
  • Tell us the game name & coding language
  • Post everything we need to know to help you
  • Ask specific questions, be descriptive
  • Post errors, line numbers & screenshots
  • Post code snippets using code tags
  • If it's a large project, zip it up and attach it

If you do not comply, your post may be deleted.  We want to help, please make a good post and we will do our best to help you.

Community Mods