Solved D3D Menu Not showing? But no compile errors

Hexui Undetected CSGO Cheats Sinkicheat PUBG Cheat

xploiitz

Coder
Fleep Tier Donator
Trump Tier Donator
Nobleman
Jul 26, 2012
155
1,698
7
So I just finished up the Tutorial on the D3DMenu, and it compiles with out error, I have tried Injecting it Using the GX-Inject provided by Fleep, and Winject, and 1 other injector which the name escapes my mind at the moment. I tried injecting it into Blacklight Retribution, Planetside, Team Fortress, Crime Craft, and a few other games. And the menu doesn't appear at all, i tried pushing insert/end to see if anything would pop up bot no success!

So I figured I might have a problem with my code. So I downloaded the source provided by Fleep, and once again tried all those games on 3 different injectors, and still no menu?

The only thing I can assume is that the hooking part of DLL isn't doing its job!?

Any ideas guys?
 

Crazywink

Hacker
Meme Tier VIP
Dank Tier Donator
Jul 18, 2012
626
4,613
17
Make sure you're injecting on start up. It has to inject right when the process is starting.
You can use my DLL injector, it has an option for Automatic Injection. https://guidedhacking.com/forum/index.php?topic=438.0

So, get everything set up before you start the game, check automatic injection, then start your game. :)


Also, if you're on Windows Vista/Windows 7, make sure you're running the injector's As Administrator. That definitely can cause problems.

crazywink
 

xploiitz

Coder
Fleep Tier Donator
Trump Tier Donator
Nobleman
Jul 26, 2012
155
1,698
7
Hmm I can't even run your injector....it crashes before I can even see a screen.
Just a typical "XXXXX Has stopped working"

I restarted my computer to make sure I wasn't having any issues with some background stuff.

I already tried running all the injectors as Administrator.... but that made no difference ! Still nothing shows up in any of the games at all :/.

Any other ideas??
 

Crazywink

Hacker
Meme Tier VIP
Dank Tier Donator
Jul 18, 2012
626
4,613
17
And you tried automatically injecting right as the game is starting?
 

xploiitz

Coder
Fleep Tier Donator
Trump Tier Donator
Nobleman
Jul 26, 2012
155
1,698
7
Yep... every single game every single time.

Nothing shows,

Out of curiosity, I ran Procexp (Process Explorer : https://technet.microsoft.com/en-us/sysinternals/bb896653.aspx)
to see if it was even injecting properly. I noticed that when using GX-Inject to inject, I couldnt find the injected DLL under the process name( that being any of the games), but if I used Winject or the other Injector, the DLL showed up under the processes.

So with that being said, I'm thinking GX-Inject uses some sort of Module cloaking, which is why I cant see the Injected DLL in ProcExp? or for some reason its not injecting at all?

I've tried everything I can think of, im not sure what else to do?
 

Crazywink

Hacker
Meme Tier VIP
Dank Tier Donator
Jul 18, 2012
626
4,613
17
Hmm.. That's really strange..

Try injecting into a D3D Test Environment (Attached).

Also what Operating System are you on, as well as 32 or 64 bit?
 

xploiitz

Coder
Fleep Tier Donator
Trump Tier Donator
Nobleman
Jul 26, 2012
155
1,698
7
I guess its worth mentioning that I'm not even bothering with my DLL anymore, just trying to inject a known working one that Fleep has supplied to us.

I have a 64 bit i7 920 processor.

I ran the D3D Test Environment , tried the injector under administrative rights and tried to inject, all say they injected successfully( didnt bother checking with ProcExp this time), but absolutely nothing pops up o_0
 

Crazywink

Hacker
Meme Tier VIP
Dank Tier Donator
Jul 18, 2012
626
4,613
17
I'm racking my brain for other possibilities but I'm coming up blank right now.. :eek:

Edit: Looks like the DLL is showing up now in ProcExp after injecting a second time.. I know that some 64-bit users have been having trouble with GX-Injector.. But as to why the other ones aren't working.. I can't figure it out..
 

xploiitz

Coder
Fleep Tier Donator
Trump Tier Donator
Nobleman
Jul 26, 2012
155
1,698
7
This is driving me nuts man... I've been looking and searching in google, and these forums and I can't even find any one else with similar problems as mine :/
 

Crazywink

Hacker
Meme Tier VIP
Dank Tier Donator
Jul 18, 2012
626
4,613
17
Sorry to keep linking you to downloads, but I'm curious if it's the DX menu.. The attached file is a really simple DX menu I created to show how to play sound.. If you want to try injecting that, I know for a fact that it is 100% working..
 

Attachments

xploiitz

Coder
Fleep Tier Donator
Trump Tier Donator
Nobleman
Jul 26, 2012
155
1,698
7
I dont mind at all... I want to figure this out as bad as you do...

Well I tried injecting the DLL you provided and im getting the same results.... nothing shows up. With all the other attempts we have tried, seems like something is up with my computer maybe?

I don't have any anti virus programs running while doing all of these tests and attempts, just incase you were wondering.
 

Crazywink

Hacker
Meme Tier VIP
Dank Tier Donator
Jul 18, 2012
626
4,613
17
It sure seems like it.. I wonder if it's the injectors.. I know on my laptop (64bit my desktop is 32) I had lots of trouble with injectors and I finally found one that worked.. I attached the one I finally got to work.
 

Attachments

xploiitz

Coder
Fleep Tier Donator
Trump Tier Donator
Nobleman
Jul 26, 2012
155
1,698
7
My collection of injectors is growing quickly lol....

same result man, nothing shows up anywhere, in any game.

No enabled AV, all injectors were ran as administrators.

Man we're really running out of options if there even is any left xD.

This really sucks.

Maybe this might help you out though?
In the other forum below, C++ help, blackpitch helped me make a DLL, for a game with some hacks, now the hack its self doesnt use any d3d code as it just patches some memory for no recoil. But playing around I noticed that Winject, DC Injector, and Injex(the one you just gave me) all inject my DLL fine, and the no recoil works.... but it doesnt not inject, or atleast has no effect at all when using GX-Inject ( the one provided by Fleep).

So I'm thinking maybe I have some issues with my D3D environment ? I dont know, you have more experience than I do it seems, Just wanted to give you as much info as possible...

I really appreciate you helping me!

 

Crazywink

Hacker
Meme Tier VIP
Dank Tier Donator
Jul 18, 2012
626
4,613
17
I'm running out of ideas here. :/ That was going to be my next suggestion to reinstall DirectX (https://www.microsoft.com/en-us/download/details-b.aspx?id=35) But that's completely up to you if you want to go through that process.. Sorry, I'm fairly new to DirectX so I'm sharing what knowledge I do know. :/


Honestly I don't have enough experience to say for sure, but to me it sounds like a D3D Environment issue like you said. :/
 

xploiitz

Coder
Fleep Tier Donator
Trump Tier Donator
Nobleman
Jul 26, 2012
155
1,698
7
Well i just uninstalled the 2004 summer SDK, and reinstalled it, made sure the correct lib / include directories were added (duh! or it wont even compile/link)

and nothing is changing....

Do you think that somehow maybe the latest version of the SDK is interfering with the 2004 version? I have june 2010 SDK and the 2004 SDK...
I really dont think it should matter since you tell the project what to include anyway. Just a thought.

 

Crazywink

Hacker
Meme Tier VIP
Dank Tier Donator
Jul 18, 2012
626
4,613
17
Yeah that shouldn't be affecting it, also because it's not working with already compiled DLLs. This is really stumping me.. I'm trying to think of any other possibilities.. Did you reinstall just the SDK?
 

Crazywink

Hacker
Meme Tier VIP
Dank Tier Donator
Jul 18, 2012
626
4,613
17
What the... XD Something's definitely messed up. Maybe try reinstalling DirectX as a whole?
 

programmer

Jr.Coder
Full Member
Nobleman
Jul 15, 2012
46
422
2
Upload your source and Somebuddy will fix that problem .
Maybe its something wrong with your source
 

Crazywink

Hacker
Meme Tier VIP
Dank Tier Donator
Jul 18, 2012
626
4,613
17
Nah, nothing with the source, he's tried Fleep's working menu, and mine, it's something with his D3D Environment I believe. :/
 
Attention! Before you post:

Read the How to Ask Questions Guide
99% of questions are answered in the Beginner's Guide, do it before asking a question.

No Hack Requests. Post in the correct section.  Search the forum first. Read the rules.

How to make a good post:

  • Fill out the form correctly
  • Tell us the game name & coding language
  • Post everything we need to know to help you
  • Ask specific questions, be descriptive
  • Post errors, line numbers & screenshots
  • Post code snippets using code tags
  • If it's a large project, zip it up and attach it

If you do not comply, your post may be deleted.  We want to help, please make a good post and we will do our best to help you.

Community Mods League of Legends Accounts