Solved Batman Special Moves Flag Pointer Problems

Hexui Undetected CSGO Cheats Sinkicheat PUBG Cheat

TheGreatUnknown

Jr.Coder
Full Member
Nobleman
Dec 20, 2012
58
417
1
So I've got the special moves flag of batman origins, I did a pointer scan and it kept scanning all through the night. I rescanned with a new address and the rescan was taking ages. So I did a 15 minute scan and stopped it. But it still takes over 2 hours to get to 50% when I rescan is there anything I can do to help with the time or is that just how it is?
 
Last edited:

Broihon

edgy 12 y/o
Escobar Tier VIP
Fleep Tier Donator
Dec 22, 2013
1,745
40,528
316
The time the pointer scan takes heavily depends on the settings of the scan. But I'd rather not use the pointer scanner anyway because it's time consuming and it takes ages until you get a stable pointer without knowing if it's actually correct.
Instead you should use the Cheat Engine debugger. Fleep made a tutorial using an older version of Cheat Engine but the technique is the same:

Make sure to use the VEH debugger. You can select it in the Debugger Options in the Cheat Engine settings. If you can't select for some reason just restart Cheat Engine and change the debugger method before attaching to the game.
 
Last edited by a moderator:

TheGreatUnknown

Jr.Coder
Full Member
Nobleman
Dec 20, 2012
58
417
1
I can't use the cheat engine debugger. I've tried what's accesses and writes to this address but all the results just have something like [EDI] but no offset. I try the result in hex as usual and I get no results at at all.
Also I'm confused by the link, fleep is just using the pointer scanner.
 
Last edited:

Broihon

edgy 12 y/o
Escobar Tier VIP
Fleep Tier Donator
Dec 22, 2013
1,745
40,528
316
I can't use the cheat engine debugger. I've tried what's accesses and writes to this address but all the results just have something like [EDI] but no offset. I try the result in hex as usual and I get no results at at all.
Also I'm confused by the link, fleep is just using the pointer scanner.
Forget the link, I just screwed up. If the accesses don't give you the offsets directly you'll have to look at the actual code to get the offset. It could be something like this:

mov edi,something
add edi,100
mov [edi],something //the actual access with offset 100

or:
lea edi,[eax+100]
mov [edi],something
 

TheGreatUnknown

Jr.Coder
Full Member
Nobleman
Dec 20, 2012
58
417
1
So use the dissembler/memory viewer on the addresses that show when written/accessed. I'll give it a go and report back :)
EDIT: Sadly this is all get for all of them no offsets http://imgur.com/a/GJ0Yr
This is the issue with finding offsets,

The value doesn't show up, there is one value which is 00000001 but it comes back with 900k results.
http://imgur.com/a/RXwXl
 
Last edited:

TheGreatUnknown

Jr.Coder
Full Member
Nobleman
Dec 20, 2012
58
417
1
I did a pointer scan and none off the results from what I can see are pointing to my flag not even to anything. Any good settings I should use that could help?
 
Last edited:
Attention! Before you post:

Read the How to Ask Questions Guide
99% of questions are answered in the Beginner's Guide, do it before asking a question.

No Hack Requests. Post in the correct section.  Search the forum first. Read the rules.

How to make a good post:

  • Fill out the form correctly
  • Tell us the game name & coding language
  • Post everything we need to know to help you
  • Ask specific questions, be descriptive
  • Post errors, line numbers & screenshots
  • Post code snippets using code tags
  • If it's a large project, zip it up and attach it

If you do not comply, your post may be deleted.  We want to help, please make a good post and we will do our best to help you.

Community Mods